워드프레스 FTP 인증 오류 해제 하는 방법

워드프레스

개요


워드프레스를 사용하시는 분들이라면 플러그인이나 각종 테마를 설치해보셨을텐데요. 처음 워드프레스를 설치 후에 플러그인이나 테마를 설치할 때 FTP 인증을 해야만 설치가 가능한데 FTP 인증이 제대로 되지 않아 골머리를 앓으시는 분들이 계실 겁니다. 이번 포스팅은 워드프레스 FTP 인증 오류 해제 하는 방법입니다.

워드프레스 FTP 인증 오류 해제하기


먼저 워드프레스 서버가 깔려있는 디렉토리 경로로 들어가서 vi 편집기로 wp-config.php 열어서 아래 코드를 추가해줍니다.

 define(‘FS_METHOD’, ‘direct’);

적당한 위치에 위 코드를 추가 해주세요. 저장 후 나옵니다.

 [root@nopiamanual ~]# $ vi /var/www/wordpress/wp-config.php
 35 /** Database Charset to use in creating database tables. */
 36 define( ‘DB_CHARSET’, ‘utf8mb4’ );
 37
 38 /** The Database Collate type. Don’t change this if in doubt. */
 39 define( ‘DB_COLLATE’, ” );
 40
 41 /** FTP 인증 무시 */
 42 define(‘FS_METHOD’, ‘direct’); 


:wq

아파치 데몬을 재시작합니다.

CentOS 7 이상 기준

 [root@nopiamanual ~]# $ systemctl restart httpd

CentOS 6 이하 기준

 [root@nopiamanual ~]# $ service restart httpd

이러면 더 이상 플러그인이나 테마 설치 시에 FTP 인증을 거치지 않아도 됩니다.

wp-config.php 설정을 해주고 아파치를 재시작 했는데도 불구하고 파일을 읽거나 쓸 수 있는 권한이 없다고 뜬다면 아래의 폴더 권한을 부여해줘야합니다.

# 권한을 줘야하는 폴더는 다음과 같습니다.

  1. wp-content
  2.  wp-content/
  3.  wp-content/plugins/
  4. wp-content/upgrade/

 [root@nopiamanual ~]# $ chmod -R 755 [폴더명]

이러면 더 이상 플러그인이나 테마 설치 시에 FTP 인증을 거치지 않아도 됩니다.

chmod로 권한을 적절히 주셨다면 플러그인 설치시 에러없이 작동이 됩니다.

댓글

답글 남기기

이메일 주소는 공개되지 않습니다. 필수 항목은 *(으)로 표시합니다

Fill out this field
Fill out this field
유효한 이메일 주소를 입력해주세요.
You need to agree with the terms to proceed

메뉴